我如何重构质量if-else语句?

发布于 2025-01-26 19:54:52 字数 1151 浏览 1 评论 0原文

我该如何对质量进行重新处理?我的应用程序中有很多大型IF-ELSE语句,我需要重构所有这些代码还是只保留它?

if (up > 80 && up < 140)
{
    if (distance)
    {
        go.transform.position = go2.transform.position;
    }
    go.transform.Translate(y, 0, x);
}
else
{
    if (down > 140)
    {
        if (distance)
        {
            go.transform.position = go2.transform.position;
        }
        go.transform.Translate(0, -y, x);
    }
    else if (down < 35)
    {
        if (distance)
        {
            go.transform.position = go2.transform.position;
        }
        go.transform.Translate(0, -y, -x);
    }
    else if (down > 35 && down < 140 && right > 0)
    {
        if (distance)
        {
            go.transform.position = go2.transform.position;
        }
        go.transform.Translate(-x, -y, 0);
    }
    else if (down > 35 && down < 140 && right < 0)
    {
        if (distance)
        {
            go.transform.position = go2.transform.position;
        }
        go.transform.Translate(x, -y, 0);
    }
}

我该如何对质量进行重新处理?我的应用程序中有很多大型IF-ELSE语句,我需要重构所有这些代码还是只保留它?

How can I refactor the mass if-else statement?? I have lots of big if-else statements in my app, do I need to refactor all this code or just leave it alone?

if (up > 80 && up < 140)
{
    if (distance)
    {
        go.transform.position = go2.transform.position;
    }
    go.transform.Translate(y, 0, x);
}
else
{
    if (down > 140)
    {
        if (distance)
        {
            go.transform.position = go2.transform.position;
        }
        go.transform.Translate(0, -y, x);
    }
    else if (down < 35)
    {
        if (distance)
        {
            go.transform.position = go2.transform.position;
        }
        go.transform.Translate(0, -y, -x);
    }
    else if (down > 35 && down < 140 && right > 0)
    {
        if (distance)
        {
            go.transform.position = go2.transform.position;
        }
        go.transform.Translate(-x, -y, 0);
    }
    else if (down > 35 && down < 140 && right < 0)
    {
        if (distance)
        {
            go.transform.position = go2.transform.position;
        }
        go.transform.Translate(x, -y, 0);
    }
}

How can I refactor the mass if-else statement?? I have lots of big if-else statements in my app, do I need to refactor all this code or just leave it alone?

如果你对这篇内容有疑问,欢迎到本站社区发帖提问 参与讨论,获取更多帮助,或者扫码二维码加入 Web 技术交流群。

扫码二维码加入Web技术交流群

发布评论

需要 登录 才能够评论, 你可以免费 注册 一个本站的账号。

评论(3

这样的小城市 2025-02-02 19:54:52

尝试一下

private static void Foo(bool distance, YourGoClass go, YourGoClass go2, double x, double y, double z)
{
    if (distance) go.transform.position = go2.transform.position;
    go.transform.Translate(x, y, z);
}

,然后您可以像这样更改代码

if (up > 80 && up < 140)
{
    Foo(distance, go, go2, y, 0, x);
}
else
{
    switch(down)
    {
        case var _ when down > 140:
            Foo(distance, go, go2, 0, -y, x);
            break;
        case var _ when down < 35:
            Foo(distance, go, go2, 0, -y, -x);
            break;
        default:
            if (right > 0) Foo(distance, go, go2, -x, -y, 0);
            else Foo(distance, go, go2, x, -y, 0);
            break;
    }
}

Try this

private static void Foo(bool distance, YourGoClass go, YourGoClass go2, double x, double y, double z)
{
    if (distance) go.transform.position = go2.transform.position;
    go.transform.Translate(x, y, z);
}

And then you can change your code like this

if (up > 80 && up < 140)
{
    Foo(distance, go, go2, y, 0, x);
}
else
{
    switch(down)
    {
        case var _ when down > 140:
            Foo(distance, go, go2, 0, -y, x);
            break;
        case var _ when down < 35:
            Foo(distance, go, go2, 0, -y, -x);
            break;
        default:
            if (right > 0) Foo(distance, go, go2, -x, -y, 0);
            else Foo(distance, go, go2, x, -y, 0);
            break;
    }
}
千柳 2025-02-02 19:54:52

您可以创建这样的方法:

private static void Translate(bool distance, YourGoClas go, YourGoClas go2, double x, double y, double z)
{
    if (distance)
    {
        go.transform.position = go2.transform.position;
    }

    go.transform.Translate(x, y, z);
}

和重构:

if (up > 80 && up < 140)
{
    Translate(distance, go, go2, y, 0, x);
}
else
{
    if (down < 35)
    {
        Translate(distance, go, go2, 0, -y, -x);
    }
    else if (down < 140)
    {
        if (right > 0)
        {
            Translate(distance, go, go2, -x, -y, 0);
        }
        else if (right < 0)
        {
            Translate(distance, go, go2, x, -y, 0);
        }
    }
    else // if (down > 140)
    {
        Translate(distance, go, go2, 0, -y, x);
    }
}

关键是寻找几乎相等的代码并以单独的方法运行。并尝试在条件下做,只有单个比较允许您分开所有情况。

You can create a method like this:

private static void Translate(bool distance, YourGoClas go, YourGoClas go2, double x, double y, double z)
{
    if (distance)
    {
        go.transform.position = go2.transform.position;
    }

    go.transform.Translate(x, y, z);
}

And refactor:

if (up > 80 && up < 140)
{
    Translate(distance, go, go2, y, 0, x);
}
else
{
    if (down < 35)
    {
        Translate(distance, go, go2, 0, -y, -x);
    }
    else if (down < 140)
    {
        if (right > 0)
        {
            Translate(distance, go, go2, -x, -y, 0);
        }
        else if (right < 0)
        {
            Translate(distance, go, go2, x, -y, 0);
        }
    }
    else // if (down > 140)
    {
        Translate(distance, go, go2, 0, -y, x);
    }
}

The key is look for code almost equal and run in a separate method. And try to do if conditions in order, only a single comparison when it's allow you separate all cases.

我恋#小黄人 2025-02-02 19:54:52

我认为您可以应用提取方法来减少重复的代码。

private void setPositionByDistance(boolean distance, Go go, Go go2) {
    if (distance)
    {
        go.transform.position = go2.transform.position;
    }
}

并使用早期返回模式,它减少了不必要的嵌套if-else层次结构。

那么您的代码将变得更好:

if (up > 80 && up < 140)
{
    setPositionByDistance(distance, go, go2);
    go.transform.Translate(y, 0, x);
    return;  // early return
}

if (down > 140)
{
    setPositionByDistance(distance, go, go2);
    go.transform.Translate(0, -y, x);
}
else if (down < 35)
{
    setPositionByDistance(distance, go, go2);
    go.transform.Translate(0, -y, -x);
}
else if (down > 35 && down < 140 && right > 0)
{
    setPositionByDistance(distance, go, go2);
    go.transform.Translate(-x, -y, 0);
}
else if (down > 35 && down < 140 && right < 0)
{
    setPositionByDistance(distance, go, go2);
    go.transform.Translate(x, -y, 0);
}

I think you could apply extract method which reduces duplicated code.

private void setPositionByDistance(boolean distance, Go go, Go go2) {
    if (distance)
    {
        go.transform.position = go2.transform.position;
    }
}

And use early return pattern, which reduces unnecessary nested if-else hierarchy.

Then your code will become better:

if (up > 80 && up < 140)
{
    setPositionByDistance(distance, go, go2);
    go.transform.Translate(y, 0, x);
    return;  // early return
}

if (down > 140)
{
    setPositionByDistance(distance, go, go2);
    go.transform.Translate(0, -y, x);
}
else if (down < 35)
{
    setPositionByDistance(distance, go, go2);
    go.transform.Translate(0, -y, -x);
}
else if (down > 35 && down < 140 && right > 0)
{
    setPositionByDistance(distance, go, go2);
    go.transform.Translate(-x, -y, 0);
}
else if (down > 35 && down < 140 && right < 0)
{
    setPositionByDistance(distance, go, go2);
    go.transform.Translate(x, -y, 0);
}
~没有更多了~
我们使用 Cookies 和其他技术来定制您的体验包括您的登录状态等。通过阅读我们的 隐私政策 了解更多相关信息。 单击 接受 或继续使用网站,即表示您同意使用 Cookies 和您的相关数据。
原文