更简单的逻辑条件来检查非空要求

发布于 2024-12-15 19:01:04 字数 277 浏览 0 评论 0原文

我有一些简单的逻辑来检查该字段是否有效:

private boolean isValidIfRequired(Object value) {
    return
        (required && !isEmpty(value)) || !required;
}

它告诉该字段如果是必需的且不为空或不是必需的,则该字段是有效的。

我不喜欢这个要求 || !必填部分。只需要一些东西就会更好。 如何简化此方法以使其更具可读性和简单性?

I have some simple logic to check if the field is valid:

private boolean isValidIfRequired(Object value) {
    return
        (required && !isEmpty(value)) || !required;
}

it tells that the field is valid if it's either required and not empty or not required.

I don't like this required || !required part. Something with just required would be better.
How do I simplify this method to make it more readable and simple?

如果你对这篇内容有疑问,欢迎到本站社区发帖提问 参与讨论,获取更多帮助,或者扫码二维码加入 Web 技术交流群。

扫码二维码加入Web技术交流群

发布评论

需要 登录 才能够评论, 你可以免费 注册 一个本站的账号。

评论(2

灯下孤影 2024-12-22 19:01:04

怎么样:

private boolean isValidIfRequired(Object value) {
    return !required || !isEmpty(value);
}

或(谢谢,@Peter Lawrey)

private boolean isValidIfRequired(Object value) {
    return !(required && isEmpty(value));
}

在任何一种情况下,如果 requiredfalse,则 ||& ;& 表达式将短路并且isEmpty 永远不会叫。如果 requiredtrue,则将评估 ||&& 的后半部分,调用isEmpty 并返回该调用的(反转)结果。

How 'bout:

private boolean isValidIfRequired(Object value) {
    return !required || !isEmpty(value);
}

or (thanks, @Peter Lawrey)

private boolean isValidIfRequired(Object value) {
    return !(required && isEmpty(value));
}

In either case, if required is false, the || or && expression will short-circuit and isEmpty will never be called. If required is true, the second half of the || or && will be evaluated, calling isEmpty and returning the (inverted) result of that call.

岁月打碎记忆 2024-12-22 19:01:04

isValidIfRequired() 的预期返回是返回 true。

因此,特殊情况必须作为监护条款放在开头:

private boolean isValidIfRequired(Object value) {

  if (required && empty(value))   //guardian clausule
      return false;

  return true;
}

对我来说,上面的代码比一起使用包含 AND 或 OR 和否定的表达式更容易阅读

The expected return of isValidIfRequired() is to return true.

So the exceptional cases must be put at the beginning as guardian clausules:

private boolean isValidIfRequired(Object value) {

  if (required && empty(value))   //guardian clausule
      return false;

  return true;
}

for me the above code is more human-readable than using together expresions containing ANDs ORs and negations

~没有更多了~
我们使用 Cookies 和其他技术来定制您的体验包括您的登录状态等。通过阅读我们的 隐私政策 了解更多相关信息。 单击 接受 或继续使用网站,即表示您同意使用 Cookies 和您的相关数据。
原文