JSTL:求两个列表的大小之和

发布于 2024-12-06 22:14:12 字数 462 浏览 2 评论 0原文

我在一个页面上有两个列表,并显示这两个列表的组合大小。

这是我的代码

<c:set var="totalAvailableVehicles" value="${fn:length(searchResult.availableVehicleList)}"/>
<c:set var="totalUvailableVehicles" value="${fn:length(searchResult.unavailableVehicleList)}"/>
<c:out value="${totalAvailableVehicles + totalUvailableVehicles}"/></strong> record found matching your search criteria</p>

有没有更好的方法可以在不编写自定义标签/函数的情况下实现相同的目标?

I have two lists on a page and showing combined size of these two lists.

Here is my code

<c:set var="totalAvailableVehicles" value="${fn:length(searchResult.availableVehicleList)}"/>
<c:set var="totalUvailableVehicles" value="${fn:length(searchResult.unavailableVehicleList)}"/>
<c:out value="${totalAvailableVehicles + totalUvailableVehicles}"/></strong> record found matching your search criteria</p>

Is there any better way to achieve same without writing custom tag/functions?

如果你对这篇内容有疑问,欢迎到本站社区发帖提问 参与讨论,获取更多帮助,或者扫码二维码加入 Web 技术交流群。

扫码二维码加入Web技术交流群

发布评论

需要 登录 才能够评论, 你可以免费 注册 一个本站的账号。

评论(1

怕倦 2024-12-13 22:14:12

我不确定你所说的“更好的方法”是什么意思。这看起来非常好。您也可以不使用 来完成此操作:

<strong><c:out value="${fn:length(searchResult.availableVehicleList) + fn:length(searchResult.unavailableVehicleList)}"/></strong> record found matching your search criteria</p>

但是,这是否具有更好的可读性/可维护性是值得怀疑的。

您还可以将其移至 SearchResult bean 的 getter 方法:

public int getTotalResultSize() {
    return availableVehicleList.size() + unavailableVehicleList.size();
}

<strong>${searchResult.totalResultSize}</strong> record found matching your search criteria</p>

注意,这里不需要 (它在JSP 2.0 及更高版本)。 的好处是对用户控制的输入进行 HTML 转义,以防止 XSS 攻击,但由于它涉及 int 类型的非用户控制输入,确实不存在XSS攻击风险。

毕竟,只要您最终获得团队认可的一定程度的可读性/可维护性,这并不重要。

I'm not sure what you mean with a "better way". This looks perfectly fine. You could also do it without <c:set>:

<strong><c:out value="${fn:length(searchResult.availableVehicleList) + fn:length(searchResult.unavailableVehicleList)}"/></strong> record found matching your search criteria</p>

However, whether that's better readable/maintainable is questionable.

You could also move that to a getter method of the SearchResult bean:

public int getTotalResultSize() {
    return availableVehicleList.size() + unavailableVehicleList.size();
}

with

<strong>${searchResult.totalResultSize}</strong> record found matching your search criteria</p>

Note that the <c:out> is not necessary here (it'll work as good in JSP 2.0 and newer). The benefit of <c:out> is the HTML-escaping of user-controlled input in order to prevent XSS attacks, but since it concerns here non-user-controlled input of type int, there is really no XSS attack risk.

After all, it really doesn't matter as long as you end up with a degree of readability/maintainability which your team agrees in.

~没有更多了~
我们使用 Cookies 和其他技术来定制您的体验包括您的登录状态等。通过阅读我们的 隐私政策 了解更多相关信息。 单击 接受 或继续使用网站,即表示您同意使用 Cookies 和您的相关数据。
原文