AIX 机器中交换信息的正则表达式

发布于 2024-11-18 20:13:24 字数 714 浏览 8 评论 0原文

AIX 中的交换信息命令:lsps -a

AIX 中的交换信息输出:

Page Space      Physical Volume   Volume Group    Size %Used Active  Auto  Type
paging00        hdisk1            rootvg        5120MB    63   yes   yes    lv
hd6             hdisk1            rootvg        4992MB    65   yes   yes    lv

如何获取 Size%Used 值?

类似于

5120MB    63
4992MB    65

更新 这就是我所做的

lsps -a | awk '{print $4" "$5}'

,这让我

Volume Volume
5120MB 63
4992MB 65 

不想要第一行Volume Volume。我可能会做 lsps -a | awk '{print $4" "$5}'|tail -2 但可以有超过 2 行:)

swap info command in AIX : lsps -a

swap info output in AIX :

Page Space      Physical Volume   Volume Group    Size %Used Active  Auto  Type
paging00        hdisk1            rootvg        5120MB    63   yes   yes    lv
hd6             hdisk1            rootvg        4992MB    65   yes   yes    lv

How can i get the Size and %Used values?

something like

5120MB    63
4992MB    65

Updated
Here is what i did

lsps -a | awk '{print $4" "$5}'

which gets me

Volume Volume
5120MB 63
4992MB 65 

I don't want the 1st line Volume Volume. I might do lsps -a | awk '{print $4" "$5}'|tail -2 but there can be more than 2 rows :)

如果你对这篇内容有疑问,欢迎到本站社区发帖提问 参与讨论,获取更多帮助,或者扫码二维码加入 Web 技术交流群。

扫码二维码加入Web技术交流群

发布评论

需要 登录 才能够评论, 你可以免费 注册 一个本站的账号。

评论(2

高速公鹿 2024-11-25 20:13:24

这个 awklette 应该可以做到。

lsps -a | awk '$1 != "Page"  { print $4 " " $5 }'

您可以使用“cut”或“sed”实现相同的效果,但我总是发现 awk 更具可读性和可靠性。

响应请求资源的评论:

此处找到了一系列漂亮的内衬

一些更深入的文档位于此处

,一个很好的教程是此处

This awklette should do it.

lsps -a | awk '$1 != "Page"  { print $4 " " $5 }'

You can achieve the same thing with "cut" or "sed" but Ive alway found awk more readable and reliable.

In response to comment requesting resources:

A collection of nifty one liners is found here here

And some more in depth documentation is here

and a good tutorial is here

谁许谁一生繁华 2024-11-25 20:13:24

该行应该满足您的需要:

lsps -a | grep -oi '[0-9]+[a-z]+[ \t]+[0-9]+'

This line should do what you need:

lsps -a | grep -oi '[0-9]+[a-z]+[ \t]+[0-9]+'
~没有更多了~
我们使用 Cookies 和其他技术来定制您的体验包括您的登录状态等。通过阅读我们的 隐私政策 了解更多相关信息。 单击 接受 或继续使用网站,即表示您同意使用 Cookies 和您的相关数据。
原文