如何命名一个从集合中获取和删除的方法?
如何命名一个从集合中获取和删除的方法?
假设我们有一个水果集合。要获取苹果,我们会执行类似 apples = Fruits.Get("apples") 的操作。删除 - Fruits.Remove(“苹果”)。如果我们想用一种方法同时执行这两项操作,它将返回苹果并将它们从集合中删除。像苹果 = Fruits.Take(“苹果”) 之类的东西。还有比“Take”更好的想法吗?
How to name a method that does getting and removal from the collection?
Say we have a collection Fruits. To get apples we would do something like apples = Fruits.Get("apples"). To remove - Fruits.Remove("apples"). If we want to do both in one method it would return apples and remove them form the collection. Something like apples = Fruits.Take("apples"). Any better ideas than "Take"?
如果你对这篇内容有疑问,欢迎到本站社区发帖提问 参与讨论,获取更多帮助,或者扫码二维码加入 Web 技术交流群。
绑定邮箱获取回复消息
由于您还没有绑定你的真实邮箱,如果其他用户或者作者回复了您的评论,将不能在第一时间通知您!
发布评论
评论(3)
remove() 或 take() 都可以。
例如:
Either remove() or take() are fine.
For example:
pop(index) 对我来说似乎是对 stack 方法的合理滥用。
pop(index) seems a reasonable misuse of stack's method to me.
有点特定于语言,但类似于:
Somewhat language specific but something like: