我应该如何命名这个函数?
function get_IfUnsetAlsoSet_SomeGlobalVariable() {
if someGlobalVariable is not set {
someGlobalVariable = somedata
}
return someGlobalVariable
}
我应该起这样的名字吗? -> getSomeGlobalVariable()
你如何命名这些 getset 函数?
function get_IfUnsetAlsoSet_SomeGlobalVariable() {
if someGlobalVariable is not set {
someGlobalVariable = somedata
}
return someGlobalVariable
}
Should I give a name like this? -> getSomeGlobalVariable()
How do you name these getset functions?
如果你对这篇内容有疑问,欢迎到本站社区发帖提问 参与讨论,获取更多帮助,或者扫码二维码加入 Web 技术交流群。
绑定邮箱获取回复消息
由于您还没有绑定你的真实邮箱,如果其他用户或者作者回复了您的评论,将不能在第一时间通知您!
发布评论
评论(3)
我想像
getSomeGlobalVariable()
这样的名称应该很简单,不会造成混淆。基本上,您不必在方法名称中给出完整的逻辑。
I guess a name like
getSomeGlobalVariable()
should be easy with no confusion.Basically you do not have to give your complete logic in a method name.
据我所知,这有点像 Singleton。所以你可以使用这个名称:
GlobalInstance();
或其他名称。As I can understand, this smells a bit like the Singleton. So you could use this name:
GlobalInstance();
or something.如果我在这里遗漏了一些东西,请原谅我,但根据你的方法
,它只做一件事,将“somedata”设置为“someGlobalVariable”。就我个人而言,我认为使用“somedata,someGlobalVariable”之类的名称不好,相反,您可以使用一些有意义的全名,如“applicationName,loggingUser 等..”
在您的情况下,基本上您正在返回一个全局变量值。
Pardon me if I'm missing something here, But as per your method
It just do one thing, will set 'somedata' to 'someGlobalVariable'. Personally I think Its not good to use names like 'somedata, someGlobalVariable' instead you may use some meaning full names like 'applicationName, loggedUser etc..'
In your case, basically you are returning a global variable value.