集合命名约定
我应该如何命名保存列宽的数组?我会使用:
int[] columnsWidths;
但我在很多地方看到类似的名称:
columnWidths
或
colWidths
当然“列的宽度”只是一个例子。
此外,我认为还有另一种情况,当2个单词不是2个单独的单词,而是创建某种名称时,例如
class TableView
在这种情况下变量的名称应该是什么样子?
TableView[] tableViews;
或者
TableView[] tablesViews;
how should I name array that holds widths of columns? I would use:
int[] columnsWidths;
but I saw in many places names like:
columnWidths
or
colWidths
Of course "widths of columns" is only an example.
Moreover, I think there is also another case, when 2 words are not 2 separate words, but create some kind of name, e.g.
class TableView
How in this case variable's name should look like?
TableView[] tableViews;
or
TableView[] tablesViews;
如果你对这篇内容有疑问,欢迎到本站社区发帖提问 参与讨论,获取更多帮助,或者扫码二维码加入 Web 技术交流群。
绑定邮箱获取回复消息
由于您还没有绑定你的真实邮箱,如果其他用户或者作者回复了您的评论,将不能在第一时间通知您!
发布评论
评论(1)
阅读代码完整。但答案没有正确或错误之分——选择适合你和你的同事的答案并保持一致。
Read Code Complete. But there is no right or wrong answer -- choose what suits you and your colleagues and be consistent.