在 Java 中创建一个新包来发出 Web 服务请求,我应该称呼它什么?
这是一个新手问题,但我对 Java 不熟悉。我在想:
com.company.webservices
或
com.company.webserviceretriever
或
com.company.webservice.retriever
任何想法或意见关于此事?
Bit of a newbie question, but I'm unfamiliar with Java. I'm thinking either:
com.company.webservices
or
com.company.webserviceretriever
or
com.company.webservice.retriever
Any thoughts or opinions on the matter?
如果你对这篇内容有疑问,欢迎到本站社区发帖提问 参与讨论,获取更多帮助,或者扫码二维码加入 Web 技术交流群。
绑定邮箱获取回复消息
由于您还没有绑定你的真实邮箱,如果其他用户或者作者回复了您的评论,将不能在第一时间通知您!
发布评论
评论(1)
没有这样硬性规定。但是 com.company.service 应该具有接口和 com.company.service.impl,您可以在其中实现内部使用 Web 服务的接口。将来,如果您想将实现从 Web 服务更改为其他服务,它仍然有意义,并且您的服务客户端不应该知道它。
There is no such hard and fast rule. But
com.company.service
should have the interface andcom.company.service.impl
in which you implement the interface which internally consumes the web service. In future if you want to change the implementation from web service to something else it will still make sense and your service client should have no idea about it.