在异步编程模型中使用什么好的命名指南?
我正在对一段代码进行一些重构,以将所有阻塞操作转换为异步操作。 我的代码是用 C# 编写的,正在执行 UPnP 查询,然后执行 HTTP 查询。 为此,我使用 UdpClient 和 WebClient 的 APM 方法(BeginReceive 等)。
我的单一方法现在是 Call_1 -> 的继承 回调_1 -> 呼叫_2 -> Callback_2 等等。
有人可以向我指出一些关于在这种情况下应该为方法命名的指南吗?知道除了 Call_1 之外的所有内容都不是我的类接口的一部分。 Callback_1、Call_2 等方法实际上只是工作流程去同步的副作用。 您会使用什么术语?
使用 CCR,所有内容都将保留在使用 Yield 关键字的单个漂亮方法中,但不幸的是,我现在不会使用 CCR。
I am doing some refactoring on a piece of code to transform all blocking operations to their async counterparts. My code is in C# and is doing an UPnP query followed by an HTTP query. For this, I use the APM methods of UdpClient and WebClient (BeginReceive, and so on).
My single method is now a succession of Call_1 -> Callback_1 -> Call_2 -> Callback_2 and so forth.
Can somebody point me to some guidelines on the names that should be given to methods in that situation, knowing that everything except Call_1 is not part of my class interface.
The methods Callback_1, Call_2, etc. are in fact just a side-effect of desynchronizing the workflow. What nomenclature would you use?
Using CCR, everything would stay in a single pretty method using the yield keyword, but unfortunately, I won't use CCR for now.
如果你对这篇内容有疑问,欢迎到本站社区发帖提问 参与讨论,获取更多帮助,或者扫码二维码加入 Web 技术交流群。
绑定邮箱获取回复消息
由于您还没有绑定你的真实邮箱,如果其他用户或者作者回复了您的评论,将不能在第一时间通知您!
发布评论
评论(1)
为了向客户端代码表达代码的意图,我将为所有具有异步行为的方法添加前缀
run
。 例如:runSOQuery
、runDiskCheck
等。也许很愚蠢,但对客户端代码来说更清晰的可能是
fireAndForget
,但不确定我是否正确理解了你的问题...最好的方法是通过返回一个特殊的 return 来表达该方法的异步语义value,就像 java.util.concurrent.Future,在 Java 或其他“自制”的情况下。
。
To express to client code what the intention of your code is, i would prefix all methods that have async behaviour with
run
. Eg:runSOQuery
,runDiskCheck
and so on.Maybe stupid but even clearer to client code could be
fireAndForget
, but not sure if I understood your question correctly...Best could be to express the async semantics of the method by returning a special return value, like a java.util.concurrent.Future, in the case of Java or something "home made", elsewhere.
.