java中实用类命名的思考
我正在寻找公共类的非功能(实用)扩展的命名指南。
在 C# 中,我曾经使用过其中的一些:
1) ListExtensions,太长,但使用扩展方法 ListExtensions 永远不会出现。 使用只是。 var ProductList = new List(); 产品列表.MyExtendedMehod();
2)列表助手。 这是在旧的 C# 2.0 时代,用法是 ListHelpers.MyExtendedMethod(productList );
现在我正在用java潜水。 我学到的是集合、数组类。 那么如何命名你的助手类呢? 集合实用程序? 收藏品? 收藏Ex?
I am looking for naming guidlines for non functional (utility) extensions of the common classes.
In C# I used to use some of this:
1) ListExtensions, too long but with extension methods ListExtensions never appears. Usage is just.
var productList = new List();
productList.MyExtendedMehod();
2) ListHelpers. This was in old C# 2.0 era, usage is ListHelpers.MyExtendedMethod(productList );
Now I am diving with java. What I have learned is Collections, Arrays classes. So how do you name your helper classes. CollectionUtils? Collections? CollectionsEx?
如果你对这篇内容有疑问,欢迎到本站社区发帖提问 参与讨论,获取更多帮助,或者扫码二维码加入 Web 技术交流群。
绑定邮箱获取回复消息
由于您还没有绑定你的真实邮箱,如果其他用户或者作者回复了您的评论,将不能在第一时间通知您!
发布评论
评论(7)
我认为 XXXUtils 是常用的方式。 然后您可以使用静态导入来删除类名。
I think XXXUtils is the common way. Then you can use static imports to get rid of the class name.
查看 Apache Commons Collections 库了解一些命名想法。 也许这个库可以做很多你想做的事情!
Check out the Apache Commons Collections library for some naming ideas. Maybe this library does a lot of things you want to do anyway!
我总是尝试使用复数形式的包名称。 它比 Util 或 Utils 短,而且听起来更像英语。
我相信 JDK 中的数组和集合听起来比它们被命名为 ArrayUtils 或 CollectionUtils 好得多。
对于火车包,我的实用程序将放置在名为 Trains 的类中。
I always try and use the package name in plural form. Its shorter than Util or Utils and it sounds more english like.
I believe Arrays and Collections from the JDK sound so much better than if they were named ArrayUtils or CollectionUtils.
For a train package my utils would be placed inside a class called Trains.
在 Java 中,有一种使用复数的模式,例如
java.util.Collections
保存相应类/包的全局类似函数的静态方法。例如,
打乱列表。
In Java there's a pattern of using plurals like
java.util.Collections
to hold global function-like static methods for the corresponding class/package.For example,
shuffles the list.
Apache Commons 通过使用 XXXUtils 模式设定了相当的标准。
Apache Commons has set quite a standard by using XXXUtils pattern.
1)我没见过很多,但我相信好的命名方案是给出一个函数名称(SynchronizedSet等)。 您可以从 Apache 的 commons-collections 或 Google 收藏集。
2)“标准”后缀是Utils - SwingUtils、StringUtils等。
1) I haven't seen it a lot, but I believe the good naming scheme is to give a functional name (SynchronizedSet, etc.). You can get examples from Apache's commons-collections or google collections.
2) The "standard" suffix is Utils - SwingUtils, StringUtils, etc.
就我个人而言,我尝试选择实用程序类名称,使类名称成为方法名称的一部分。 例如
诸如此类...
Personally I try to choose utility class names such that the clase name is part of the method name. For example
et cetera...