我应该在我的方法前面加上“get”前缀吗? 或“负载” 与网络服务通信时?
我正在编写一个与 Web 服务通信的桌面应用程序。 您会将所有获取数据的 Web 服务函数命名为 LoadXXXX,因为它们需要一段时间才能执行。 或者您会使用 GetXXXX,例如仅获取单个对象时。
I'm writing a desktop application that communicates with a web service. Would you name all web-service functions that that fetch data LoadXXXX, since they take a while to execute. Or would you use GetXXXX, for instance when getting just a single object.
如果你对这篇内容有疑问,欢迎到本站社区发帖提问 参与讨论,获取更多帮助,或者扫码二维码加入 Web 技术交流群。
绑定邮箱获取回复消息
由于您还没有绑定你的真实邮箱,如果其他用户或者作者回复了您的评论,将不能在第一时间通知您!
发布评论
评论(6)
当方法返回 XXXX 时,使用 MyObject.GetXXXX()。
当 XXXX 将被加载到 MyObject 时,换句话说,当 MyObject 保持对 XXXX 的控制时,请使用 MyObject.LoadXXXX()。
我想这同样适用于网络服务。
Use MyObject.GetXXXX() when the method returns XXXX.
Use MyObject.LoadXXXX() when XXXX will be loaded into MyObject, in other words, when MyObject keeps control of XXXX.
The same applies to webservices, I guess.
如果您希望它花费“文件时间”,我会使用 Load;如果您希望它花费“简单数据库”时间,我会使用 Get。
也就是说,如果调用费用昂贵,请使用“Load”。
I would use Load if you expect it to take "file-time" and Get if you expect it to take "simple DB" time.
That is, if the call is expensive, use "Load".
获取。 然后提供一种异步调用它们的方法,以强调它们可能会出去吃午饭一段时间......
Get. And then provide a way of calling them asynchronously to emphasize that they may be out to lunch for a while...
当我读到LoadXXX时,我已经在想数据来自某些存储介质。 由于 Web 服务位于云端,因此 GetXXX 感觉更自然。
When I read LoadXXX, I'm already thinking that the data comes from some storage media. Since the web service is up in the cloud, GetXXX feels more natural.
始终使用 Get,除非实际加载某些内容(例如,将文件加载到内存中)。
Always use Get, except perhaps when actually loading something (eg, loading a file into memory).
做动词所暗示的事情。 GetXXX 意味着某些内容正在返回给调用者,而 LoadXXX 不一定返回某些内容,因为它可能只是将某些内容加载到内存中。
对于 API,请使用 GetXXX 向调用者明确将返回某些内容。
Do what the verb implies. GetXXX implies that something is being returned to the caller, while LoadXXX doesn't necessarily return something as it may be just loading something into memory.
For an API, use GetXXX to be clear to the caller that something will be returned.